初学者向けプログラミング学習環境 PEN 開発メモWiki

マニュアル/xDNCL/条件分岐

条件分岐

条件文 (1) if ~ then 文

もし ≪条件式≫ ならば
  | ≪処理≫
を実行する

≪条件式≫が真の場合、≪処理≫を実行し、偽の場合は≪処理≫を実行しない。
いずれの場合もその後に次の文へ制御を渡す。

使用例

もし x = 10 ならば
  | 「条件が成立しました」 を表示する
を実行する
「終了」 を表示する

変数 x が 10 の場合の出力例

条件が成立しました
終了

変数 x が 5 の場合の出力例

終了

条件文 (2) if ~ then ~ else 文

もし ≪条件式≫ ならば
  | ≪処理1≫
を実行し,そうでなければ
  | ≪処理2≫
を実行する

≪条件式≫が真の場合、≪処理1≫を実行し、偽の場合は≪処理2≫を実行する。

使用例

もし x = 20 ならば
  | 「条件が成立しました」 を表示する
を実行し,そうでなければ
  | 「条件が成立しませんでした」 を表示する
を実行する
「終了」 を表示する

変数 x が 20 の場合の出力例

条件が成立しました
終了

変数 x が 10 の場合の出力例

条件が成立しませんでした
終了

条件文 (3) else ~ if 文

もし ≪条件式≫ ならば
  | ≪処理1≫
を実行し,そうでなくもし ≪条件式2≫ ならば
  | ≪処理2≫
を実行し,そうでなければ
  | ≪処理3≫
を実行する

≪条件式1≫が成立した場合、≪処理1≫を実行し、
成立しなくて≪条件式2≫が成立した場合、≪処理2≫を実行し、
どの条件式も成立しない場合は≪処理3≫を実行する。

使用例

もし x >= 80 ならば
  | 「xは80以上です」を表示する
を実行し,そうでなくもし x >= 60 ならば
  | 「xは79~60の間です」を表示する
を実行し,そうでなければ
  | 「xは59以下です」を表示する
を実行する

変数 x が 95 の場合の出力例

xは80以上です

変数 x が 70 の場合の出力例

xは79~60の間です

変数 x が 30 の場合の出力例

xは59以下です

条件文 (4) switch 文

Menu

Wikiについて

最近の更新